lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erick Erickson <erickerick...@gmail.com>
Subject Re: [jira] Commented: (LUCENE-2308) Separately specify a field's type
Date Fri, 12 Mar 2010 18:59:17 GMT
Congrats Chris!

I vote for thinkAboutNotIncludingNormsMaybe(true|false) <G>.....

Seriously double negatives are ugly IMO, +1 for changing....

Erick

On Fri, Mar 12, 2010 at 12:56 PM, Chris Male (JIRA) <jira@apache.org> wrote:

>
>    [
> https://issues.apache.org/jira/browse/LUCENE-2308?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12844587#action_12844587]
>
> Chris Male commented on LUCENE-2308:
> ------------------------------------
>
> I agree entirely.  This is definitely the moment to remove any ambiguity or
> confusion in this API.  I'll make sure to incorporate this idea.
>
> > Separately specify a field's type
> > ---------------------------------
> >
> >                 Key: LUCENE-2308
> >                 URL: https://issues.apache.org/jira/browse/LUCENE-2308
> >             Project: Lucene - Java
> >          Issue Type: Improvement
> >          Components: Index
> >            Reporter: Michael McCandless
> >
> > This came up from dicussions on IRC.  I'm summarizing here...
> > Today when you make a Field to add to a document you can set things
> > index or not, stored or not, analyzed or not, details like omitTfAP,
> > omitNorms, index term vectors (separately controlling
> > offsets/positions), etc.
> > I think we should factor these out into a new class (FieldType?).
> > Then you could re-use this FieldType instance across multiple fields.
> > The Field instance would still hold the actual value.
> > We could then do per-field analyzers by adding a setAnalyzer on the
> > FieldType, instead of the separate PerFieldAnalzyerWrapper (likewise
> > for per-field codecs (with flex), where we now have
> > PerFieldCodecWrapper).
> > This would NOT be a schema!  It's just refactoring what we already
> > specify today.  EG it's not serialized into the index.
> > This has been discussed before, and I know Michael Busch opened a more
> > ambitious (I think?) issue.  I think this is a good first baby step.  We
> could
> > consider a hierarchy of FIeldType (NumericFieldType, etc.) but maybe hold
> > off on that for starters...
>
> --
> This message is automatically generated by JIRA.
> -
> You can reply to this email to add a comment to the issue online.
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
> For additional commands, e-mail: java-dev-help@lucene.apache.org
>
>

Mime
View raw message