lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steven Rowe (JIRA)" <>
Subject [jira] Commented: (LUCENE-2358) rename KeywordMarkerTokenFilter
Date Tue, 30 Mar 2010 23:12:27 GMT


Steven Rowe commented on LUCENE-2358:

Hi Robert,

I'm working on a change to ShingleFilter to not output "_" filler token unigrams (or generally,
filler-only ngrams, to cover the case where position increment gaps exceed n).  

I needed to be able to mark cached tokens as being filler tokens (or not) - a boolean attribute.
 After trying to write a new private-use attribute and failing (I didn't make both an interface
and an implementation, I think - I should figure it out and improve the docs I guess), I found
KeywordAttribute and have used it to mark whether or not a cached token is a filler token
(keyword:yes => filler-token:yes).

Would it make sense to have a generalized boolean attribute, specialized for keywords or (fill-in-the-blank)?
 It's a small leap to say that "iskeyword" means true for whatever boolean attribute you want
to carry, so this isn't really a big deal, but I thought I'd bring it up while you're thinking
about naming this thing.

(This may be a can of worms: if there  is a generic boolean attribute, should there be generic
string/int/float/etc. attributes too?)


> rename KeywordMarkerTokenFilter
> -------------------------------
>                 Key: LUCENE-2358
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Task
>          Components: Analysis
>            Reporter: Robert Muir
>            Priority: Trivial
>         Attachments: LUCENE-2358.patch
> I would like to rename KeywordMarkerTokenFilter to KeywordMarkerFilter.
> We havent released it yet, so its a good time to keep the name brief and consistent.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message