lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Uwe Schindler" <...@thetaphi.de>
Subject RE: lucene and solr trunk
Date Tue, 16 Mar 2010 09:08:09 GMT
Hi,

> And Lucene is on Java 1.5 and should be compiled with an 1.5 compiler,
> where Solr seems to be on 1.6 since yesterday? (Yonik added something
> to common-build.xml). On my development system I have no Java 1.6
> installed at all as default build, I ever use Java 1.5 for building
> Lucene. If we merge that and have both on different JVMs the same
> problems like with 1.4/1.5 start. Developers use 1.6 methods because
> their compiler does not warn them. So everybody working on Lucene
> should at least have Java 1.5 compiler and try to compile his changes
> before committing. I do this (as I use 1.5 for developing), 1.6 on some
> of our servers.
> 
> So: If merge, keep both on Java 1.5 !!!

I changed common-build.xml in the new solr branch to Java 1.5 again, as there is currently
no reason to change this and especially as it was not discussed anywhere.

Java 1.5 as base for both solr and lucene is better and the few features of Java 1.6 does
not rectify to move up. I have my development area configured with Java 1.5 and I only develop
Lucene in 1.5. I am then sure to not use the wrong methods when creating patches. You can
still tell users to run with JRE 1.6, but development should stay on 1.5 for now.

Uwe


---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org


Mime
View raw message