lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael McCandless <luc...@mikemccandless.com>
Subject Re: svn commit: r829773 - in /lucene/java/branches/lucene_2_9: CHANGES.txt contrib/CHANGES.txt
Date Mon, 26 Oct 2009 14:36:37 GMT
I just thought it was best to move it there since it's deprecating
APIs on a dot-release (something we don't normally do according to
back-compat policy).

But I agree on trunk it should just be under API changes.  OK I'll move it back.

And actually in 3.0 I don't think we need separate CHANGES entries for
all deprecation removals?  I think we can just have an uber-entry that
says "removed all deprecated APIs from 2.9.x"?

Mike

On Mon, Oct 26, 2009 at 9:16 AM, Uwe Schindler <uwe@thetaphi.de> wrote:
> We should change the text a little bit in 2.9 because it only deprecates the
> API there, it does not break in BW.
>
> In 3.0 we should then move all deprecation removal to backwards breaks, but
> this would be somehow strange.
>
> -----
> Uwe Schindler
> H.-H.-Meier-Allee 63, D-28213 Bremen
> http://www.thetaphi.de
> eMail: uwe@thetaphi.de
>
>
>> -----Original Message-----
>> From: mikemccand@apache.org [mailto:mikemccand@apache.org]
>> Sent: Monday, October 26, 2009 1:43 PM
>> To: java-commits@lucene.apache.org
>> Subject: svn commit: r829773 - in /lucene/java/branches/lucene_2_9:
>> CHANGES.txt contrib/CHANGES.txt
>>
>> Author: mikemccand
>> Date: Mon Oct 26 12:43:26 2009
>> New Revision: 829773
>>
>> URL: http://svn.apache.org/viewvc?rev=829773&view=rev
>> Log:
>> LUCENE-2002 (on 2.9 branch): move CHANGES entry under 'Changes in back
>> compat policy' section, since it deprecates APIs
>>
>> Modified:
>>     lucene/java/branches/lucene_2_9/CHANGES.txt
>>     lucene/java/branches/lucene_2_9/contrib/CHANGES.txt
>>
>> Modified: lucene/java/branches/lucene_2_9/CHANGES.txt
>> URL:
>> http://svn.apache.org/viewvc/lucene/java/branches/lucene_2_9/CHANGES.txt?r
>> ev=829773&r1=829772&r2=829773&view=diff
>> ==========================================================================
>> ====
>> --- lucene/java/branches/lucene_2_9/CHANGES.txt (original)
>> +++ lucene/java/branches/lucene_2_9/CHANGES.txt Mon Oct 26 12:43:26 2009
>> @@ -3,6 +3,13 @@
>>
>>  ======================= 2.9 branch (not yet released)
>> =======================
>>
>> +Changes in backwards compatibility policy
>> +
>> + * LUCENE-2002: Add required Version matchVersion argument when
>> +   constructing QueryParser or MultiFieldQueryParser and, default (as
>> +   of 2.9) enablePositionIncrements to true to match
>> +   StandardAnalyzer's 2.9 default (Uwe Schindler, Mike McCandless)
>> +
>>  Bug fixes
>>
>>   * LUCENE-1974: Fixed nasty bug in BooleanQuery (when it used
>> @@ -42,11 +49,6 @@
>>     settings in StandardAnalyzer to be compatible with the coming
>>     Lucene 3.0.  (Uwe Schindler)
>>
>> - * LUCENE-2002: Add required Version matchVersion argument when
>> -   constructing QueryParser or MultiFieldQueryParser and, default (as
>> -   of 2.9) enablePositionIncrements to true to match
>> -   StandardAnalyzer's 2.9 default (Uwe Schindler, Mike McCandless)
>> -
>>  Documentation
>>
>>   * LUCENE-1955: Fix Hits deprecation notice to point users in right
>>
>> Modified: lucene/java/branches/lucene_2_9/contrib/CHANGES.txt
>> URL:
>> http://svn.apache.org/viewvc/lucene/java/branches/lucene_2_9/contrib/CHANG
>> ES.txt?rev=829773&r1=829772&r2=829773&view=diff
>> ==========================================================================
>> ====
>> --- lucene/java/branches/lucene_2_9/contrib/CHANGES.txt (original)
>> +++ lucene/java/branches/lucene_2_9/contrib/CHANGES.txt Mon Oct 26
>> 12:43:26 2009
>> @@ -4,6 +4,12 @@
>>
>>  Changes in backwards compatibility policy
>>
>> + * LUCENE-2002: Add required Version matchVersion argument when
>> +   constructing ComplexPhraseQueryParser and default (as of 2.9)
>> +   enablePositionIncrements to true to match StandardAnalyzer's
>> +   default.  Also added required matchVersion to most of the analyzers
>> +   (Uwe Schindler, Mike McCandless)
>> +
>>  Changes in runtime behavior
>>
>>   * LUCENE-1963: ArabicAnalyzer now lowercases before checking the
>> stopword
>> @@ -11,15 +17,6 @@
>>     stopword list that contains some non-Arabic words, you'll need to
>> fully
>>     reindex.  (DM Smith via Robert Muir)
>>
>> -API Changes:
>> -
>> - * LUCENE-2002: Add required Version matchVersion argument when
>> -   constructing ComplexPhraseQueryParser and default (as of 2.9)
>> -   enablePositionIncrements to true to match StandardAnalyzer's
>> -   default.  Also added required matchVersion to most of the analyzers
>> -   (Uwe Schindler, Mike McCandless)
>> -
>> -
>>  Bug fixes
>>
>>   * LUCENE-1953: FastVectorHighlighter: small fragCharSize can cause
>>
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
> For additional commands, e-mail: java-dev-help@lucene.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org


Mime
View raw message