lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael McCandless <luc...@mikemccandless.com>
Subject Re: Lucene 2.9 and deprecated IR.open() methods
Date Sat, 03 Oct 2009 10:29:28 GMT
On Sat, Oct 3, 2009 at 6:25 AM, Uwe Schindler <uwe@thetaphi.de> wrote:
> Now it gets slower. After applying LUCENE-1944, you get >600 errors when
> compiling tests :(
>
> We should have checked our tests in 2.9 that they only call deprecated
> methods for BW compatibility.

Sigh.  Yes, going forward we should probably always fix tests to not
use deprecated APIs anymore, at the same time that we deprecate.

> No I have to change tons of IR.open(), IW()
> calls in backwards branch and also in trunk tests. But the patch is
> currently the same for both branches - puh.

Maybe we should re-cut the back-compat branch after removal of all
deprecated APIs?

> Completely unhappy :-(

Sorry :(  Take a deep breath.  Go consume some coffee or dark
chocolate (or, maybe, a beer!) :)

Mike

---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org


Mime
View raw message