lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Uwe Schindler" <...@thetaphi.de>
Subject RE: Lucene 2.9 and deprecated IR.open() methods
Date Sat, 03 Oct 2009 11:59:59 GMT
This seems to work, I have created some scripts that do the compilations and
create a deprecation report and I start to fix in BW branch. The easieist is
first to just remove a lot of tests, that only test the BW compatibility
API.

I will post something, as soon as I have removed most deprec warnings.

-----
Uwe Schindler
H.-H.-Meier-Allee 63, D-28213 Bremen
http://www.thetaphi.de
eMail: uwe@thetaphi.de


> -----Original Message-----
> From: Uwe Schindler [mailto:uwe@thetaphi.de]
> Sent: Saturday, October 03, 2009 12:39 PM
> To: java-dev@lucene.apache.org
> Subject: RE: Lucene 2.9 and deprecated IR.open() methods
> 
> I have a plan how to do the tests:
> 
> I use my BW branch checkout and enable deprecation warnings there. I then
> start to fix  all deprec usage and remove all code parts that are only
> there
> to test bw compatibility (e.g. TestTokenStreamBWCompatibiliy). After that
> the test should compile without deprec warnings. When this is done commit
> and create new TAG.
> 
> After that apply the patch also to trunk -> tests should compile :-)
> 
> -----
> Uwe Schindler
> H.-H.-Meier-Allee 63, D-28213 Bremen
> http://www.thetaphi.de
> eMail: uwe@thetaphi.de
> 
> 
> > -----Original Message-----
> > From: Uwe Schindler [mailto:uwe@thetaphi.de]
> > Sent: Saturday, October 03, 2009 12:33 PM
> > To: java-dev@lucene.apache.org
> > Subject: RE: Lucene 2.9 and deprecated IR.open() methods
> >
> > > From: Michael McCandless [mailto:lucene@mikemccandless.com]
> > > Sent: Saturday, October 03, 2009 12:29 PM
> > > To: java-dev@lucene.apache.org
> > > Subject: Re: Lucene 2.9 and deprecated IR.open() methods
> > >
> > > On Sat, Oct 3, 2009 at 6:25 AM, Uwe Schindler <uwe@thetaphi.de> wrote:
> > > > Now it gets slower. After applying LUCENE-1944, you get >600 errors
> > when
> > > > compiling tests :(
> > > >
> > > > We should have checked our tests in 2.9 that they only call
> deprecated
> > > > methods for BW compatibility.
> > >
> > > Sigh.  Yes, going forward we should probably always fix tests to not
> > > use deprecated APIs anymore, at the same time that we deprecate.
> > > > Now I have to change tons of IR.open(), IW()
> > > > calls in backwards branch and also in trunk tests. But the patch is
> > > > currently the same for both branches - puh.
> > >
> > > Maybe we should re-cut the back-compat branch after removal of all
> > > deprecated APIs?
> >
> >
> > No, better apply the patch on both branches. Because I changed generics
> in
> > TokenStream API and want to be sure, that not generified BW branch
> works.
> > Now it would not even compile anymore, because BW branch is forced to
> Java
> > 1.4. The simpliest is really to create a patch and apply it to both
> > branches
> > or merge it using SVN. That's my smallest problem.
> >
> > > > Completely unhappy :-(
> > >
> > > Sorry :(  Take a deep breath.  Go consume some coffee or dark
> > > chocolate (or, maybe, a beer!) :)
> > >
> > > Mike
> > >
> > > ---------------------------------------------------------------------
> > > To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
> > > For additional commands, e-mail: java-dev-help@lucene.apache.org
> >
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
> > For additional commands, e-mail: java-dev-help@lucene.apache.org
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
> For additional commands, e-mail: java-dev-help@lucene.apache.org



---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org


Mime
View raw message