lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Karl Wettin (JIRA)" <j...@apache.org>
Subject [jira] Commented: (LUCENE-1939) IndexOutOfBoundsException at ShingleMatrixFilter's Iterator#hasNext method
Date Sat, 03 Oct 2009 12:46:23 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-1939?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12761868#action_12761868
] 

Karl Wettin commented on LUCENE-1939:
-------------------------------------

Patrick,

I can't manage to reproduce this error. Uwe is right though, you are getting this error using
2.4.1 or earlier, not by using 2.9.

bq. 	at org.apache.lucene.analysis.shingle.ShingleMatrixFilter$Matrix$1.hasNext(ShingleMatrixFilter.java:729)

Can you please try with 2.9? It would also be very helpful if you could list the applicable
Solr configurations and some example data you are passing to the filter when it's thrown.

Thanks in advance.


> IndexOutOfBoundsException at ShingleMatrixFilter's Iterator#hasNext method
> --------------------------------------------------------------------------
>
>                 Key: LUCENE-1939
>                 URL: https://issues.apache.org/jira/browse/LUCENE-1939
>             Project: Lucene - Java
>          Issue Type: Bug
>          Components: contrib/analyzers
>    Affects Versions: 2.9
>            Reporter: Patrick Jungermann
>            Assignee: Karl Wettin
>         Attachments: ShingleMatrixFilter_IndexOutOfBoundsException.patch
>
>
> I tried to use the ShingleMatrixFilter within Solr. To test the functionality etc., I
first used the built-in field analysis view.The filter was configured to be used only at query
time analysis with "_" as spacer character and a min. and max. shingle size of 2. The generation
of the shingles for query strings with this filter seems to work at this view, but by turn
on the highlighting of indexed terms that will match the query terms, the exception was thrown.
Also, each time I tried to query the index the exception was immediately thrown.
> Stacktrace:
> {code}
> java.lang.IndexOutOfBoundsException: Index: 1, Size: 1
> 	at java.util.ArrayList.RangeCheck(Unknown Source)
> 	at java.util.ArrayList.get(Unknown Source)
> 	at org.apache.lucene.analysis.shingle.ShingleMatrixFilter$Matrix$1.hasNext(ShingleMatrixFilter.java:729)
> 	at org.apache.lucene.analysis.shingle.ShingleMatrixFilter.next(ShingleMatrixFilter.java:380)
> 	at org.apache.lucene.analysis.StopFilter.next(StopFilter.java:120)
> 	at org.apache.lucene.analysis.TokenStream.next(TokenStream.java:47)
> 	...
> {code}
> Within the hasNext method, there is the {{s-1}}-th Column from the ArrayList {{columns}}
requested, but there isn't this entry within columns.
> I created a patch that checks, if {{columns}} contains enough entries.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org


Mime
View raw message