lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Muir (JIRA)" <>
Subject [jira] Commented: (LUCENE-1887) o.a.l.messages should be moved/renamed
Date Wed, 02 Sep 2009 22:56:32 GMT


Robert Muir commented on LUCENE-1887:

I agree it would be nice to have a package for localized messages in general.
In the future this leaves open the door for localization of other parts of lucene.

since it uses MessageFormat etc, I think it would be very reusable.

> o.a.l.messages should be moved/renamed
> --------------------------------------
>                 Key: LUCENE-1887
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Improvement
>            Reporter: Hoss Man
>            Priority: Minor
>             Fix For: 2.9
> contrib/queryParser contains an org.apache.lucene.messages package containing some generallized
code that (claims in it's javadocs) is not specific to the queryParser.
> If this is truely general purpose code, it should probably be moved out of hte queryParser
contrib -- either into it's own contrib, or into the core (it's very small)
> Alternately: if the code isn't super reusable, the package name should probably be changed
to be a subpackage of  org.apache.lucene.queryParser ... it tends to be very confusing when
all of the code in a contrib doesn't fall into a clear organizational namespace.
> I've marked this issue for 2.9 so we at least think about it prior to release ... it
is a brand new public API, so this is out best chance to change it if we want ... but it is
by no means a blocker for 2.9

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message