lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Luis Alves (JIRA)" <>
Subject [jira] Commented: (LUCENE-1887) o.a.l.messages should be moved to it's own contrib
Date Thu, 10 Sep 2009 02:11:57 GMT


Luis Alves commented on LUCENE-1887:

I agree with you on the compatibility, I'll remove the deprecated from the getLocalizedMessage
method on 
NLS class and submit again
public static String getLocalizedMessage(String key, Locale locale, Object[] args)

I just think it is ugly having to create a Object array for every call to the Message classes.
See Example below.

Original or with my patch
throw new ParseException(new MessageImpl(QueryParserMessages.INVALID_SYNTAX_ESCAPE_NONE_HEX_UNICODE,

Example using your patch:
throw new ParseException(new MessageImpl(QueryParserMessages.INVALID_SYNTAX_ESCAPE_NONE_HEX_UNICODE,
new Object[]{c}));

This is not a big thing for me.
If we don't care that the users of these classes in 2.9 are required to create the object
arrays for most method calls, then
I am totally ok with your patch.

We can clean the new QueryParser code, of those object arrays in 3.0.

Robert or Mark pick any of the patches, they both look good to me.
Need to go home, I'll check the issue later.

> o.a.l.messages should be moved to it's own contrib
> --------------------------------------------------
>                 Key: LUCENE-1887
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: contrib/*
>            Reporter: Hoss Man
>            Priority: Minor
>         Attachments: lucene-1877-new.patch, LUCENE-1887.patch
> contrib/queryParser contains an org.apache.lucene.messages package containing some generallized
code that (claims in it's javadocs) is not specific to the queryParser.
> If this is truely general purpose code, it should probably be moved out of hte queryParser
contrib -- either into it's own contrib, or into the core (it's very small)
> *EDIT:* alternate suggestion to rename package to fall under the o.a.l.queryParser namespace
retracted due to comments in favor of (eventually) promoting to it's own contrib

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message