lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Luis Alves (JIRA)" <>
Subject [jira] Commented: (LUCENE-1887) o.a.l.messages should be moved to it's own contrib
Date Thu, 10 Sep 2009 01:43:58 GMT


Luis Alves commented on LUCENE-1887:

I looked at Robert's patch it is very similar to mine, 
but Robert changed the testcases and the queryparser code to use a new method signature.

My patch added more utility methods (deprecated) on NLS and MessageImpl and does not require
any changes the QP and the tescases.

I prefer my approach because it will be compatible to jdk1.5, once we remove the utility methods
from these classes and revert back to the jdk 1.5 syntax in 3.0.

Robert please take a look at my patch and see if you like it.

> o.a.l.messages should be moved to it's own contrib
> --------------------------------------------------
>                 Key: LUCENE-1887
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: contrib/*
>            Reporter: Hoss Man
>            Priority: Minor
>         Attachments: lucene-1877-new.patch, LUCENE-1887.patch
> contrib/queryParser contains an org.apache.lucene.messages package containing some generallized
code that (claims in it's javadocs) is not specific to the queryParser.
> If this is truely general purpose code, it should probably be moved out of hte queryParser
contrib -- either into it's own contrib, or into the core (it's very small)
> *EDIT:* alternate suggestion to rename package to fall under the o.a.l.queryParser namespace
retracted due to comments in favor of (eventually) promoting to it's own contrib

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message