lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Miller <markrmil...@gmail.com>
Subject Re: [VOTE] Release Lucene 2.9.0
Date Thu, 24 Sep 2009 18:18:29 GMT
Andi Vajda wrote:
>
> On Thu, 24 Sep 2009, Chris Hostetter wrote:
>
>>
>> : - db/bdb fails to compile with 1.4 because of a ClassFormatError in
>> one of
>> : the bundled libs, so this contrib is in reality 1.5 only.
>>
>> there's not much we can do about that, no one can blame us if the
>> dependency requires 1.5
>
> I don't think it requires it, it was most likely compiled with Java
> 1.5 or even 1.6. I thought that we had agreed that it didn't matter if
> contribs 'required' java 1.5 ?
>
> Andi..
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
> For additional commands, e-mail: java-dev-help@lucene.apache.org
>
Indeed - but for those contribs that are 1.4, we have tried to keep them
1.4 - especially core"y" contribs like Highlighter.

But overall, they don't promise back compat - which is why we are not
going to worry about this (the needed votes are in and I'm going to
publish faster than anyone can pull them ;) )

-- 
- Mark

http://www.lucidimagination.com




---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org


Mime
View raw message