lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris Harris (JIRA)" <>
Subject [jira] Updated: (LUCENE-1903) Incorrect ShingleFilter behavior when outputUnigrams == false
Date Tue, 08 Sep 2009 21:06:57 GMT


Chris Harris updated LUCENE-1903:

    Attachment: TEST-org.apache.lucene.analysis.shingle.ShingleFilterTest.xml

Attaching a patch that adds three new ShingleFilter tests. Two of the new tests do not pass;
these are testBiGramFilterWithoutUnigrams and testBiGramFilterWithSingleTokenWithoutUnigrams.

Also attaching the XML output from my junit run.

> Incorrect ShingleFilter behavior when outputUnigrams == false
> -------------------------------------------------------------
>                 Key: LUCENE-1903
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Bug
>          Components: contrib/analyzers
>            Reporter: Chris Harris
>         Attachments: LUCENE-1903_testcases.patch, TEST-org.apache.lucene.analysis.shingle.ShingleFilterTest.xml
> ShingleFilter isn't working as expected when outputUnigrams == false. In particular,
it is outputting unigrams at least some of the time when outputUnigrams==false.
> I'll attach a patch to that adds some test cases that demonstrate
the problem.
> I haven't checked this, but I hypothesize that the behavior for outputUnigrams == false
got changed when the class was upgraded to the new TokenStream API?

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message