lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Adriano Crestani (JIRA)" <j...@apache.org>
Subject [jira] Commented: (LUCENE-1887) o.a.l.messages should be moved to it's own contrib
Date Wed, 09 Sep 2009 23:37:57 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-1887?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12753328#action_12753328
] 

Adriano Crestani commented on LUCENE-1887:
------------------------------------------

+1 to make it 1.4 compatible and move it to core in 2.9

+1 to move it to another contrib project called, e.g. "messages"

I think Hoss made his point about not leaving this code in queryparser contrib project and
I agree.

> o.a.l.messages should be moved to it's own contrib
> --------------------------------------------------
>
>                 Key: LUCENE-1887
>                 URL: https://issues.apache.org/jira/browse/LUCENE-1887
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: contrib/*
>            Reporter: Hoss Man
>            Priority: Minor
>
> contrib/queryParser contains an org.apache.lucene.messages package containing some generallized
code that (claims in it's javadocs) is not specific to the queryParser.
> If this is truely general purpose code, it should probably be moved out of hte queryParser
contrib -- either into it's own contrib, or into the core (it's very small)
> *EDIT:* alternate suggestion to rename package to fall under the o.a.l.queryParser namespace
retracted due to comments in favor of (eventually) promoting to it's own contrib

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org


Mime
View raw message