lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hoss Man (JIRA)" <j...@apache.org>
Subject [jira] Updated: (LUCENE-1887) o.a.l.messages should be moved to it's own contrib
Date Tue, 08 Sep 2009 18:15:57 GMT

     [ https://issues.apache.org/jira/browse/LUCENE-1887?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Hoss Man updated LUCENE-1887:
-----------------------------

    Component/s: contrib/*
    Description: 
contrib/queryParser contains an org.apache.lucene.messages package containing some generallized
code that (claims in it's javadocs) is not specific to the queryParser.

If this is truely general purpose code, it should probably be moved out of hte queryParser
contrib -- either into it's own contrib, or into the core (it's very small)

*EDIT:* alternate suggestion to rename package to fall under the o.a.l.queryParser namespace
retracted due to comments in favor of (eventually) promoting to it's own contrib

  was:
contrib/queryParser contains an org.apache.lucene.messages package containing some generallized
code that (claims in it's javadocs) is not specific to the queryParser.

If this is truely general purpose code, it should probably be moved out of hte queryParser
contrib -- either into it's own contrib, or into the core (it's very small)

Alternately: if the code isn't super reusable, the package name should probably be changed
to be a subpackage of  org.apache.lucene.queryParser ... it tends to be very confusing when
all of the code in a contrib doesn't fall into a clear organizational namespace.

I've marked this issue for 2.9 so we at least think about it prior to release ... it is a
brand new public API, so this is out best chance to change it if we want ... but it is by
no means a blocker for 2.9

        Summary: o.a.l.messages should be moved to it's own contrib  (was: o.a.l.messages
should be moved/renamed)

> o.a.l.messages should be moved to it's own contrib
> --------------------------------------------------
>
>                 Key: LUCENE-1887
>                 URL: https://issues.apache.org/jira/browse/LUCENE-1887
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: contrib/*
>            Reporter: Hoss Man
>            Priority: Minor
>
> contrib/queryParser contains an org.apache.lucene.messages package containing some generallized
code that (claims in it's javadocs) is not specific to the queryParser.
> If this is truely general purpose code, it should probably be moved out of hte queryParser
contrib -- either into it's own contrib, or into the core (it's very small)
> *EDIT:* alternate suggestion to rename package to fall under the o.a.l.queryParser namespace
retracted due to comments in favor of (eventually) promoting to it's own contrib

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org


Mime
View raw message