lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Luis Alves (JIRA)" <j...@apache.org>
Subject [jira] Issue Comment Edited: (LUCENE-1887) o.a.l.messages should be moved to it's own contrib
Date Wed, 09 Sep 2009 18:05:58 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-1887?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12753181#action_12753181
] 

Luis Alves edited comment on LUCENE-1887 at 9/9/09 11:04 AM:
-------------------------------------------------------------

The original idea is to have messages and the new queryparser moved into core on 3.0. But
this was discussed in the mailing list and the community thinks it's better to give it some
more time for the API's on the new QP to get stable and allow more time for review of the
new queryparser.

I think there is an understanding to move the new QueryParser to core, when 3.1 is released.

When the new messages and the queryparser is moved to core, it will be more usable.  If we
keep it on contrib, in my opinion we should leave it as is for release 2.9 and 3.0

We should re-look at this issue when 3.0 is done, by moving message and the queryparser to
core.



      was (Author: lafa):
    The original idea is to have messages and the new queryparser moved into main on 3.0.
But this was discussed in the mailing list and the community thinks it's better to give it
some more time for the API's to get stable and allow more time for review of the new queryparser.

I think there is an understanding to move the new QueryParser to main, when 3.1 is released.

When the new messages and the queryparser is moved to main, it will be more usable. In my
opinion we should leave it as is for release 2.9 and 3.0, and look at this issue when 3.0
is done, by moving messages to main and probably the queryparser to main.


  
> o.a.l.messages should be moved to it's own contrib
> --------------------------------------------------
>
>                 Key: LUCENE-1887
>                 URL: https://issues.apache.org/jira/browse/LUCENE-1887
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: contrib/*
>            Reporter: Hoss Man
>            Priority: Minor
>
> contrib/queryParser contains an org.apache.lucene.messages package containing some generallized
code that (claims in it's javadocs) is not specific to the queryParser.
> If this is truely general purpose code, it should probably be moved out of hte queryParser
contrib -- either into it's own contrib, or into the core (it's very small)
> *EDIT:* alternate suggestion to rename package to fall under the o.a.l.queryParser namespace
retracted due to comments in favor of (eventually) promoting to it's own contrib

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org


Mime
View raw message