lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Luis Alves (JIRA)" <>
Subject [jira] Commented: (LUCENE-1887) o.a.l.messages should be moved to it's own contrib
Date Wed, 09 Sep 2009 17:39:57 GMT


Luis Alves commented on LUCENE-1887:

The original idea is to have messages and the new queryparser moved into main on 3.0. But
this was discussed in the mailing list and the community thinks it's better to give it some
more time for the API's to get stable and allow more time for review of the new queryparser.

I think there is an understanding to move the new QueryParser to main, when 3.1 is released.

When the new messages and the queryparser is moved to main, it will be more usable. In my
opinion we should leave it as is for release 2.9 and 3.0, and look at this issue when 3.0
is done, by moving messages to main and probably the queryparser to main.

> o.a.l.messages should be moved to it's own contrib
> --------------------------------------------------
>                 Key: LUCENE-1887
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: contrib/*
>            Reporter: Hoss Man
>            Priority: Minor
> contrib/queryParser contains an org.apache.lucene.messages package containing some generallized
code that (claims in it's javadocs) is not specific to the queryParser.
> If this is truely general purpose code, it should probably be moved out of hte queryParser
contrib -- either into it's own contrib, or into the core (it's very small)
> *EDIT:* alternate suggestion to rename package to fall under the o.a.l.queryParser namespace
retracted due to comments in favor of (eventually) promoting to it's own contrib

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message