lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Uwe Schindler (JIRA)" <j...@apache.org>
Subject [jira] Updated: (LUCENE-1887) o.a.l.messages should be moved to core
Date Thu, 10 Sep 2009 06:28:57 GMT

     [ https://issues.apache.org/jira/browse/LUCENE-1887?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Uwe Schindler updated LUCENE-1887:
----------------------------------

    Fix Version/s: 2.9

> o.a.l.messages should be moved to core
> --------------------------------------
>
>                 Key: LUCENE-1887
>                 URL: https://issues.apache.org/jira/browse/LUCENE-1887
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: contrib/*
>            Reporter: Hoss Man
>            Assignee: Mark Miller
>            Priority: Minor
>             Fix For: 2.9
>
>         Attachments: lucene-1877-new-v2.patch, lucene-1877-new.patch, LUCENE-1887-javadocs-all.patch,
LUCENE-1887.patch
>
>
> contrib/queryParser contains an org.apache.lucene.messages package containing some generallized
code that (claims in it's javadocs) is not specific to the queryParser.
> If this is truely general purpose code, it should probably be moved out of hte queryParser
contrib -- either into it's own contrib, or into the core (it's very small)
> *EDIT:* alternate suggestion to rename package to fall under the o.a.l.queryParser namespace
retracted due to comments in favor of (eventually) promoting to it's own contrib

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org


Mime
View raw message