lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Grant Ingersoll <>
Subject Re: BoostingNearQuery
Date Fri, 21 Aug 2009 12:25:37 GMT

On Aug 20, 2009, at 3:39 PM, Mark Miller wrote:

> In a similar line though, BoostingFunctionTermQuery doesn't really fit
> with BoostingNearQuery. I see part of why its not called
> BoostingTermQuery is because BoostingTermQuery is deprecated - but why
> can't the BoostingFunctionTermQuery impl replace BoostingTermQuery  
> with
> average as the default? (which is now how the deprecated
> BoostingTermQuery is implemented) There doesn't seem a good reason we
> abandoned it. And as all these types will take functions, there is no
> reason to have that in the name if BoostingNearQuery doesn't need it.

It could.  I guess it was just a product of how I was thinking about  
it at the time.  BTQ was deprecated b/c it is trivial to do it as a  
BFTQ.  In reality, they are both bad names.  It should be called,  
simply, PayloadTermQuery (or PayloadFunctionTermQuery) and  

So, maybe we should keep BTQ deprecated and renamed BTFQ to be the  
PayloadTermQuery and BoostingNearQuery to be PayloadNearQuery.


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message