lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Luis Alves (JIRA)" <j...@apache.org>
Subject [jira] Issue Comment Edited: (LUCENE-1782) Rename OriginalQueryParserHelper
Date Thu, 06 Aug 2009 01:15:14 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-1782?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12739838#action_12739838
] 

Luis Alves edited comment on LUCENE-1782 at 8/5/09 6:13 PM:
------------------------------------------------------------

{quote}
renamed StandardQueryParserHelper to simply QueryParser, and stripped
Standard prefix off a bunch of classes.
{quote}

I don't like the idea of "stripped Standard prefix" or "StandardQueryParserHelper to simply
QueryParser".

My reason for this, is that this change will make it more difficult for users
that want to use several implementations of diff parsers at same time.

QueryParserHelper can be renamed to QueryParser,
but the other classes should keep the prefix name to avoid name conflicts,
when using multiple parsers.

{code}
example (seudo java):

oqp = new OriginaleQueryParser(); 
cpqp = new ComplexPhraseQueryParser(); 

q1 = oqp.parser("normal query");
q2 = cpqp.parser("complex string");

b = new BooleanQuery();

b.add(q1);
b.add(q2);
{code}



      was (Author: lafa):
    {quote}
renamed StandardQueryParserHelper to simply QueryParser, and stripped
Standard prefix off a bunch of classes.
{quote}

I don't like the idea of "stripped Standard prefix" or "StandardQueryParserHelper to simply
QueryParser".

My reason for this, is that this change will make it more difficult for users
that want to use several implementations of diff parsers at same time.

QueryParserHelper can be renamed to QueryParser,
but the other classes should keep the prefix name to avoid name conflicts,
when using multiple parsers.

example (seudo java):

oqp = new OriginaleQueryParser(); 
cpqp = new ComplexPhraseQueryParser(); 

q1 = oqp.parser("normal query");
q2 = cpqp.parser("complex string");

b = new BooleanQuery();

b.add(q1);
b.add(q2);



  
> Rename OriginalQueryParserHelper
> --------------------------------
>
>                 Key: LUCENE-1782
>                 URL: https://issues.apache.org/jira/browse/LUCENE-1782
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: contrib/*
>    Affects Versions: 2.9
>            Reporter: Michael McCandless
>            Assignee: Michael McCandless
>            Priority: Minor
>             Fix For: 2.9
>
>         Attachments: LUCENE-1782.patch
>
>
> We should rename the new QueryParser so it's clearer that it's
> Lucene's default QueryParser, going forward, and not just a temporary
> "bridge" to a future new QueryParser.
> How about we rename oal.queryParser.original -->
> oal.queryParser.standard (can't use "default": it's a Java keyword)?
> Then, leave the OriginalQueryParserHelper under that package, but
> simply rename it to QueryParser?
> This way if we create other sub-packages in the future, eg
> ComplexPhraseQueryParser, they too can have a QueryParser class under
> them, to make it clear that's the "top" class you use to parse
> queries.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org


Mime
View raw message