lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Miller <markrmil...@gmail.com>
Subject Re: Finishing Lucene 2.9
Date Sun, 23 Aug 2009 18:46:11 GMT
Simon Willnauer wrote:
>
>  Having 3.0
> with 1.4 back-compat and then 3.1 which get rid of this would confuse
> users.
>
> simon
>   
>
If that was really a concern (and we decided to jump to 3.0), we could
just say this 3.0 release requires Java 1.5 - 3.0 and beyond can still
be considered Java 1.5. Even though 3.0 itself still happens to run on
Java 1.4. We are not going to convert *everything* to Java 1.5 when we
move to it on the first release. We also don't have to convert anything
to say we now require it.

Personally, I wouldn't be too worried about it either way. Following
Changes correctly and with a solid understanding is 100x times more
difficult and confusing.

-- 
- Mark

http://www.lucidimagination.com




---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org


Mime
View raw message