lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael McCandless (JIRA)" <>
Subject [jira] Created: (LUCENE-1782) Rename OriginalQueryParserHelper
Date Wed, 05 Aug 2009 00:20:14 GMT
Rename OriginalQueryParserHelper

                 Key: LUCENE-1782
             Project: Lucene - Java
          Issue Type: Improvement
          Components: contrib/*
    Affects Versions: 2.9
            Reporter: Michael McCandless
            Assignee: Michael McCandless
            Priority: Minor
             Fix For: 2.9

We should rename the new QueryParser so it's clearer that it's
Lucene's default QueryParser, going forward, and not just a temporary
"bridge" to a future new QueryParser.

How about we rename oal.queryParser.original -->
oal.queryParser.standard (can't use "default": it's a Java keyword)?
Then, leave the OriginalQueryParserHelper under that package, but
simply rename it to QueryParser?

This way if we create other sub-packages in the future, eg
ComplexPhraseQueryParser, they too can have a QueryParser class under
them, to make it clear that's the "top" class you use to parse

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message