lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael McCandless (JIRA)" <j...@apache.org>
Subject [jira] Commented: (LUCENE-1782) Rename OriginalQueryParserHelper
Date Wed, 05 Aug 2009 23:21:14 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-1782?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12739817#action_12739817
] 

Michael McCandless commented on LUCENE-1782:
--------------------------------------------

I plan to commit this in the next day or so...

> Rename OriginalQueryParserHelper
> --------------------------------
>
>                 Key: LUCENE-1782
>                 URL: https://issues.apache.org/jira/browse/LUCENE-1782
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: contrib/*
>    Affects Versions: 2.9
>            Reporter: Michael McCandless
>            Assignee: Michael McCandless
>            Priority: Minor
>             Fix For: 2.9
>
>         Attachments: LUCENE-1782.patch
>
>
> We should rename the new QueryParser so it's clearer that it's
> Lucene's default QueryParser, going forward, and not just a temporary
> "bridge" to a future new QueryParser.
> How about we rename oal.queryParser.original -->
> oal.queryParser.standard (can't use "default": it's a Java keyword)?
> Then, leave the OriginalQueryParserHelper under that package, but
> simply rename it to QueryParser?
> This way if we create other sub-packages in the future, eg
> ComplexPhraseQueryParser, they too can have a QueryParser class under
> them, to make it clear that's the "top" class you use to parse
> queries.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org


Mime
View raw message