lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael McCandless (JIRA)" <j...@apache.org>
Subject [jira] Commented: (LUCENE-1782) Rename OriginalQueryParserHelper
Date Wed, 05 Aug 2009 18:15:14 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-1782?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12739653#action_12739653
] 

Michael McCandless commented on LUCENE-1782:
--------------------------------------------

OK I have a huge patch working, but then I went to run JavaCC to regenerate the parser to
make sure I've fixed the .jj file correctly, and there wasn't a javacc target in the build.xml.
 So I added one (in build.xml) and ran javacc and got warnings like this:
{code}
Warning: ParseException.java: File is obsolete.  Please rename or delete this file so that
a new one can be generated for you.
{code}

So I removed ParseException.java and let JavaCC make a new one, but then hit compilation errors
because the old ParseException.java manually subclassed from QueryNodeParseException (which
is nice).   So I simply copied the old one back... is this expected?  Ie there's no way to
customize how JavaCC generates its ParseException.java, so we manually override it?  If so,
I'll add comment to build.xml saying so.

> Rename OriginalQueryParserHelper
> --------------------------------
>
>                 Key: LUCENE-1782
>                 URL: https://issues.apache.org/jira/browse/LUCENE-1782
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: contrib/*
>    Affects Versions: 2.9
>            Reporter: Michael McCandless
>            Assignee: Michael McCandless
>            Priority: Minor
>             Fix For: 2.9
>
>
> We should rename the new QueryParser so it's clearer that it's
> Lucene's default QueryParser, going forward, and not just a temporary
> "bridge" to a future new QueryParser.
> How about we rename oal.queryParser.original -->
> oal.queryParser.standard (can't use "default": it's a Java keyword)?
> Then, leave the OriginalQueryParserHelper under that package, but
> simply rename it to QueryParser?
> This way if we create other sub-packages in the future, eg
> ComplexPhraseQueryParser, they too can have a QueryParser class under
> them, to make it clear that's the "top" class you use to parse
> queries.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org


Mime
View raw message