lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Miller <markrmil...@gmail.com>
Subject Re: Lucene contrib build failing on jdk 1.4
Date Tue, 14 Jul 2009 00:41:58 GMT
Hey Adriano,

Only core is fully 1.4. To build all of contrib you must use at least java
1.5. If you want to build a contrib that is supposed to 1.4 with 1.4, use
the individual build file for that contrib.

-- 
- Mark

http://www.lucidimagination.com


On Mon, Jul 13, 2009 at 7:44 PM, Adriano Crestani <
adrianocrestani@apache.org> wrote:

> Hi,
>
> I checked out Lucene java trunk and ran "build-contrib". When I run using
> Sun JDK 1.6.0_07 it builds successfully, but using Sun JDK 1.4.2_19 I get
> the error below. Am I doing something wrong?
>
> Thanks in advance,
> Adriano Crestani Campos
>
> ...
> build-artifacts-and-tests:
>
> bdb:
>
> BUILD FAILED
> /home/adcampos/lucene/trunk2/build.xml:626: The following error occurred
> while executing this line:
> /home/adcampos/lucene/trunk2/build.xml:616: The following error occurred
> while executing this line:
> /home/adcampos/lucene/trunk2/contrib/db/build.xml:29: The following error
> occurred while executing this line:
> /home/adcampos/lucene/trunk2/contrib/db/bdb/build.xml:14:
> java.lang.UnsupportedClassVersionError: com/sleepycat/db/internal/Db
> (Unsupported major.minor version 49.0)
>
> Total time: 17 seconds
>
>

Mime
View raw message