lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eks Dev (JIRA)" <>
Subject [jira] Created: (LUCENE-1762) Slightly more readable code in TermAttributeImpl
Date Sat, 25 Jul 2009 13:22:14 GMT
Slightly more readable code in TermAttributeImpl 

                 Key: LUCENE-1762
             Project: Lucene - Java
          Issue Type: Improvement
          Components: Analysis
            Reporter: Eks Dev
            Priority: Trivial

No big deal. 

growTermBuffer(int newSize) was using correct, but slightly hard to follow code. 

the method was returning null as a hint that the current termBuffer has enough space to the
upstream code or reallocated buffer.

this patch simplifies logic   making this method to only reallocate buffer, nothing more.
It reduces number of if(null) checks in a few methods and reduces amount of code. 
all tests pass.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message