lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eks Dev (JIRA)" <>
Subject [jira] Updated: (LUCENE-1762) Slightly more readable code in TermAttributeImpl
Date Sat, 25 Jul 2009 23:13:14 GMT


Eks Dev updated LUCENE-1762:

    Attachment: LUCENE-1762.patch

- made allocation in initTermBuffer() consistent with ArrayUtil.getNextSize(int) -  this is
ok not to start with MIN_BUFFER_SIZE, but rather with ArrayUtil.getNextSize(MIN_BUFFER_SIZE)...
e.g. if getNextSize gets very sensitive to initial conditions one day...
- null-ed  termText on switch to termBuffer in resizeTermBuffer (as it was before!) . This
was a bug in previous patch  

> Slightly more readable code in TermAttributeImpl 
> -------------------------------------------------
>                 Key: LUCENE-1762
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: Analysis
>            Reporter: Eks Dev
>            Assignee: Uwe Schindler
>            Priority: Trivial
>         Attachments: LUCENE-1762.patch, LUCENE-1762.patch, LUCENE-1762.patch
> No big deal. 
> growTermBuffer(int newSize) was using correct, but slightly hard to follow code. 
> the method was returning null as a hint that the current termBuffer has enough space
to the upstream code or reallocated buffer.
> this patch simplifies logic   making this method to only reallocate buffer, nothing more.
> It reduces number of if(null) checks in a few methods and reduces amount of code. 
> all tests pass.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message