lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eks Dev (JIRA)" <j...@apache.org>
Subject [jira] Commented: (LUCENE-1762) Slightly more readable code in TermAttributeImpl
Date Mon, 27 Jul 2009 22:22:14 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-1762?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12735809#action_12735809
] 

Eks Dev commented on LUCENE-1762:
---------------------------------

cool, thanks for the review.   

> Slightly more readable code in TermAttributeImpl 
> -------------------------------------------------
>
>                 Key: LUCENE-1762
>                 URL: https://issues.apache.org/jira/browse/LUCENE-1762
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: Analysis
>    Affects Versions: 2.9
>            Reporter: Eks Dev
>            Assignee: Uwe Schindler
>            Priority: Trivial
>             Fix For: 2.9
>
>         Attachments: LUCENE-1762.patch, LUCENE-1762.patch, LUCENE-1762.patch, LUCENE-1762.patch
>
>
> No big deal. 
> growTermBuffer(int newSize) was using correct, but slightly hard to follow code. 
> the method was returning null as a hint that the current termBuffer has enough space
to the upstream code or reallocated buffer.
> this patch simplifies logic   making this method to only reallocate buffer, nothing more.
 
> It reduces number of if(null) checks in a few methods and reduces amount of code. 
> all tests pass.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org


Mime
View raw message