lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Uwe Schindler (JIRA)" <>
Subject [jira] Commented: (LUCENE-1713) Rename RangeQuery -> TermRangeQuery
Date Tue, 30 Jun 2009 08:12:47 GMT


Uwe Schindler commented on LUCENE-1713:

Should I prepare a patch later?

I would simply rename the files in core and then change the tests and rest to find any references
to the old RangeQuery/Filter (compile failures). After that I create a deprecated subclass
of TermRange* with the old name and all ctors from the old class. The new class will only
supply the new ctors (no deprecated ones using Term, mapping is done in the subclass).

> Rename RangeQuery -> TermRangeQuery
> -----------------------------------
>                 Key: LUCENE-1713
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Improvement
>    Affects Versions: 2.9
>            Reporter: Michael McCandless
>             Fix For: 2.9
> Since we now have NumericRangeQuery (LUCENE-1701) we should rename RangeQuery to TextRangeQuery
to make it clear that TextRangeQuery (TermRangeQuery?  StringRangeQuery) is based entirely
on text comparison.
> And, existing users on upgrading to 2.9 and using RangeQuery for [slow] numeric searching
would realize they now have a good option for numeric range searching.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message