lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Uwe Schindler (JIRA)" <>
Subject [jira] Assigned: (LUCENE-1713) Rename RangeQuery -> TermRangeQuery
Date Tue, 30 Jun 2009 09:37:47 GMT


Uwe Schindler reassigned LUCENE-1713:

    Assignee: Uwe Schindler

bq. Yes feel free to take this one Uwe, thanks! That approach (and using svn move/copy) sounds

I was the "bad-boy" who invented NumericRangeQuery, so I have to take this one and clean up
the rest of Lucene for this change.

> Rename RangeQuery -> TermRangeQuery
> -----------------------------------
>                 Key: LUCENE-1713
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Improvement
>    Affects Versions: 2.9
>            Reporter: Michael McCandless
>            Assignee: Uwe Schindler
>             Fix For: 2.9
> Since we now have NumericRangeQuery (LUCENE-1701) we should rename RangeQuery to TextRangeQuery
to make it clear that TextRangeQuery (TermRangeQuery?  StringRangeQuery) is based entirely
on text comparison.
> And, existing users on upgrading to 2.9 and using RangeQuery for [slow] numeric searching
would realize they now have a good option for numeric range searching.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message