Return-Path: Delivered-To: apmail-lucene-java-dev-archive@www.apache.org Received: (qmail 30698 invoked from network); 21 May 2009 09:55:04 -0000 Received: from hermes.apache.org (HELO mail.apache.org) (140.211.11.3) by minotaur.apache.org with SMTP; 21 May 2009 09:55:04 -0000 Received: (qmail 3492 invoked by uid 500); 21 May 2009 09:55:16 -0000 Delivered-To: apmail-lucene-java-dev-archive@lucene.apache.org Received: (qmail 3404 invoked by uid 500); 21 May 2009 09:55:16 -0000 Mailing-List: contact java-dev-help@lucene.apache.org; run by ezmlm Precedence: bulk List-Help: List-Unsubscribe: List-Post: List-Id: Reply-To: java-dev@lucene.apache.org Delivered-To: mailing list java-dev@lucene.apache.org Received: (qmail 3396 invoked by uid 99); 21 May 2009 09:55:16 -0000 Received: from nike.apache.org (HELO nike.apache.org) (192.87.106.230) by apache.org (qpsmtpd/0.29) with ESMTP; Thu, 21 May 2009 09:55:16 +0000 X-ASF-Spam-Status: No, hits=-2000.0 required=10.0 tests=ALL_TRUSTED X-Spam-Check-By: apache.org Received: from [140.211.11.140] (HELO brutus.apache.org) (140.211.11.140) by apache.org (qpsmtpd/0.29) with ESMTP; Thu, 21 May 2009 09:55:06 +0000 Received: from brutus (localhost [127.0.0.1]) by brutus.apache.org (Postfix) with ESMTP id 867DF234C004 for ; Thu, 21 May 2009 02:54:45 -0700 (PDT) Message-ID: <640630238.1242899685536.JavaMail.jira@brutus> Date: Thu, 21 May 2009 02:54:45 -0700 (PDT) From: "Michael McCandless (JIRA)" To: java-dev@lucene.apache.org Subject: [jira] Commented: (LUCENE-1614) Add next() and skipTo() variants to DocIdSetIterator that return the current doc, instead of boolean In-Reply-To: <848873297.1240634970628.JavaMail.jira@brutus> MIME-Version: 1.0 Content-Type: text/plain; charset=utf-8 Content-Transfer-Encoding: 7bit X-JIRA-FingerPrint: 30527f35849b9dde25b450d4833f0394 X-Virus-Checked: Checked by ClamAV on apache.org [ https://issues.apache.org/jira/browse/LUCENE-1614?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12711545#action_12711545 ] Michael McCandless commented on LUCENE-1614: -------------------------------------------- bq. OpenBitSetIterator already has a nextDoc() method which returns -1 when exhausted. Hmm -- maybe we need to choose a different name than nextDoc()? Or... we make a new class (DISI2 or something) so we can strongly differentiate old from new semantics? bq. I tend to say MAX_VAL should not be a valid value Right, we are saying (have already said, elsewhere in Lucene's core code) that MAX_VAL is not a valid docID. bq. MAX_VAL is considered a valid value for SortedVIntList (TestSortedVIntList.test03() validates that). So if we use it as sentinel, we declare that MAX_VAL is invalid for SortedVIntList. Not sure if we can do that. I think we should remove that test, and decide MAX_VAL is not valid value in the list, because SortedVIntList is a DocIdSet. bq. BTW, besides the convenience, why should SortedVIntList expose a DocIdSetIterator? I don't follow -- SortedVIntList subclasses DocIdSet, which necessarily provides DISI iterator() method. Why is this not a "true DISI"? > Add next() and skipTo() variants to DocIdSetIterator that return the current doc, instead of boolean > ---------------------------------------------------------------------------------------------------- > > Key: LUCENE-1614 > URL: https://issues.apache.org/jira/browse/LUCENE-1614 > Project: Lucene - Java > Issue Type: Improvement > Components: Search > Reporter: Shai Erera > Fix For: 2.9 > > Attachments: LUCENE-1614.patch > > > See http://www.nabble.com/Another-possible-optimization---now-in-DocIdSetIterator-p23223319.html for the full discussion. The basic idea is to add variants to those two methods that return the current doc they are at, to save successive calls to doc(). If there are no more docs, return -1. A summary of what was discussed so far: > # Deprecate those two methods. > # Add nextDoc() and skipToDoc(int) that return doc, with default impl in DISI (calls next() and skipTo() respectively, and will be changed to abstract in 3.0). > #* I actually would like to propose an alternative to the names: advance() and advance(int) - the first advances by one, the second advances to target. > # Wherever these are used, do something like '(doc = advance()) >= 0' instead of comparing to -1 for improved performance. > I will post a patch shortly -- This message is automatically generated by JIRA. - You can reply to this email to add a comment to the issue online. --------------------------------------------------------------------- To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org For additional commands, e-mail: java-dev-help@lucene.apache.org