lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael McCandless <luc...@mikemccandless.com>
Subject Re: Lucene's default settings & back compatibility
Date Fri, 22 May 2009 15:33:33 GMT
On Thu, May 21, 2009 at 6:53 PM, Marvin Humphrey <marvin@rectangular.com> wrote:

> Lastly, I think a major java Lucene release is justified already.
> Won't this discussion die down somewhat if you can get 3.0 out?

Somewhat, yes, but then when working on 3.1 if we make some great
improvement, I'd like new users in 3.1 to see the improvement by
default.  So I'd like to resolve this for 2.9/3.0.

But I agree we gotta wrap 2.9 and move on.  It will feel great,
removing code & fixing defaults in 3.0!

> Full-on schema serialization isn't feasible for Lucene, but
> attaching an actsAsVersion variable to an index and feeding that to
> your analyzers would be a decent start.

On thinking about it more... automagically storing the "actsAsVersion"
in the index, and then having IndexWriter (for example) ask the
analyzer for a tokenStream matching that version, seems a little too
sneaky.  I prefer the up-front "you specify actsAsVersion" when you
create the analyzer, only for analyzers that have changed across
releases.  So things like WhitespaceAnalyzer would likely never need
an actsAsVersion arg.

Mike

---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org


Mime
View raw message