lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael McCandless (JIRA)" <>
Subject [jira] Commented: (LUCENE-1614) Add next() and skipTo() variants to DocIdSetIterator that return the current doc, instead of boolean
Date Tue, 19 May 2009 20:05:45 GMT


Michael McCandless commented on LUCENE-1614:

> I wonder if instead of returning -1 when the iteration is done, we should return Integer.MAX_VALUE?

The idea was to return a negative value and then compare the returned value to >= 0 for
better performance. If we return MAX_VAL we'll need to compare to MAX_VAL, which is less efficient,
CPU wise.

If you always check the returned result, right.

But with BooleanScorer/2, and likely any scorer that invokes multiple
sub-scorers, switching to Integer.MAX_INT as the sentinel would allow
us to *not* test every sub-scorer's returned result from
nextDoc/advance.  Ie, because the docID moved forward (vs -1, which
moved backwards), it's a "natural" fit for the main scorer's normal docID
processing.  So, far fewer if's (one per subscorer) are in the
innermost loop.

Marvin, what's your plan for Lucy's sentinel value for DISI/Scorer?

> Add next() and skipTo() variants to DocIdSetIterator that return the current doc, instead
of boolean
> ----------------------------------------------------------------------------------------------------
>                 Key: LUCENE-1614
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: Search
>            Reporter: Shai Erera
>             Fix For: 2.9
>         Attachments: LUCENE-1614.patch
> See
for the full discussion. The basic idea is to add variants to those two methods that return
the current doc they are at, to save successive calls to doc(). If there are no more docs,
return -1. A summary of what was discussed so far:
> # Deprecate those two methods.
> # Add nextDoc() and skipToDoc(int) that return doc, with default impl in DISI (calls
next() and skipTo() respectively, and will be changed to abstract in 3.0).
> #* I actually would like to propose an alternative to the names: advance() and advance(int)
- the first advances by one, the second advances to target.
> # Wherever these are used, do something like '(doc = advance()) >= 0' instead of comparing
to -1 for improved performance.
> I will post a patch shortly

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message