lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Erik Hatcher (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (LUCENE-1635) Handle Escape character
Date Thu, 14 May 2009 12:58:45 GMT

     [ https://issues.apache.org/jira/browse/LUCENE-1635?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Erik Hatcher resolved LUCENE-1635.
----------------------------------

    Resolution: Invalid

This isn't a bug.  If you're using SimpleAnalyzer, it makes sense that it is splitting it
up.  Escaping just allows the characters to pass through as-is to the analyzer.

> Handle Escape character
> -----------------------
>
>                 Key: LUCENE-1635
>                 URL: https://issues.apache.org/jira/browse/LUCENE-1635
>             Project: Lucene - Java
>          Issue Type: Bug
>          Components: QueryParser
>    Affects Versions: 2.0.0
>         Environment: Os-Windows,J2EE
>            Reporter: rimi
>            Priority: Critical
>
> I have tried to search using the query :AWT-T.The query parser is returning "awt t".It's
removing the - special character.If I try to find using the query :AWT\-T then also the query
parser is returning the same query "awt t". I have used simpleAnalyzer. Please help me.I want
to search using the - character and that's why I put AWT\-T because \ will escape the special
character.But it's not working in its way.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org


Mime
View raw message