lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shai Erera (JIRA)" <>
Subject [jira] Commented: (LUCENE-1614) Add next() and skipTo() variants to DocIdSetIterator that return the current doc, instead of boolean
Date Tue, 19 May 2009 20:19:45 GMT


Shai Erera commented on LUCENE-1614:

Ok I'll look into it tomorrow morning when I'll be near the code again. If it makes sense,
then it makes sense :)

You're also right about TermScorer. I missed the fact that checking the pointer occurs for
the _next_ pointer, and indeed now the code does one extra check than before.

If you don't feel advance() should have this contract, then I can change TermScorer's implementation
back and document that calling advance() with the same value several times in a row does not
guarantee to return the same value every time ... 

I still think it's more logical to state that it should return the same value, however since
I don't have a good scenario where that will happen (and perhaps the fact that nobody complained
about it until now means it never happens?) and since it may pose a performance hit over some
iterators, I'm willing to let go :)

> Add next() and skipTo() variants to DocIdSetIterator that return the current doc, instead
of boolean
> ----------------------------------------------------------------------------------------------------
>                 Key: LUCENE-1614
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: Search
>            Reporter: Shai Erera
>             Fix For: 2.9
>         Attachments: LUCENE-1614.patch
> See
for the full discussion. The basic idea is to add variants to those two methods that return
the current doc they are at, to save successive calls to doc(). If there are no more docs,
return -1. A summary of what was discussed so far:
> # Deprecate those two methods.
> # Add nextDoc() and skipToDoc(int) that return doc, with default impl in DISI (calls
next() and skipTo() respectively, and will be changed to abstract in 3.0).
> #* I actually would like to propose an alternative to the names: advance() and advance(int)
- the first advances by one, the second advances to target.
> # Wherever these are used, do something like '(doc = advance()) >= 0' instead of comparing
to -1 for improved performance.
> I will post a patch shortly

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message