lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael McCandless (JIRA)" <>
Subject [jira] Commented: (LUCENE-1614) Add next() and skipTo() variants to DocIdSetIterator that return the current doc, instead of boolean
Date Wed, 27 May 2009 11:58:45 GMT


Michael McCandless commented on LUCENE-1614:

bq. I prefer to defer DISI.start/finish until it's actually needed.

I agree.  I'm thinking at this point that neither should be needed.  start() should be done
on creating the Scorer, and finish() should not be needed because Scorers ought to be lightweight
enough to not need closeable resources.  If one makes a custom Scorer one can always close
it outside of Lucene.

bq. BTW Mike, docID()'s contract states that is should return -1 if nextDoc()/advance() weren't

Right, so this should mean the "firstTime" logic should be removable from all core Scorers.

bq. Also, I've done the changes to BS and the code looks much more simpler. Working on DMS

Fabulous :)  Can't wait to see it!

> Add next() and skipTo() variants to DocIdSetIterator that return the current doc, instead
of boolean
> ----------------------------------------------------------------------------------------------------
>                 Key: LUCENE-1614
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: Search
>            Reporter: Shai Erera
>             Fix For: 2.9
>         Attachments: LUCENE-1614.patch, LUCENE-1614.patch, LUCENE-1614.patch
> See
for the full discussion. The basic idea is to add variants to those two methods that return
the current doc they are at, to save successive calls to doc(). If there are no more docs,
return -1. A summary of what was discussed so far:
> # Deprecate those two methods.
> # Add nextDoc() and skipToDoc(int) that return doc, with default impl in DISI (calls
next() and skipTo() respectively, and will be changed to abstract in 3.0).
> #* I actually would like to propose an alternative to the names: advance() and advance(int)
- the first advances by one, the second advances to target.
> # Wherever these are used, do something like '(doc = advance()) >= 0' instead of comparing
to -1 for improved performance.
> I will post a patch shortly

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message