lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shai Erera (JIRA)" <>
Subject [jira] Commented: (LUCENE-1614) Add next() and skipTo() variants to DocIdSetIterator that return the current doc, instead of boolean
Date Wed, 27 May 2009 04:42:45 GMT


Shai Erera commented on LUCENE-1614:

bq. One minor disadvantage of removing such firstTime booleans is that during scorer construction
the index may have to be accessed because some constructors will use the next() method on
their subscorers.

I don't see any difference between instantiating BS and immediately after that calling add
several times to instantiating BS with the scorers. Accessing the index, to me, seems to be

In fact, by removing add() and passing the scorers in the ctor we can also get rid of redundant
code in add(). Currently, it checks if the scorer is required/prohibited/both, but both does
not happen in reality and in each add only required or prohibited is set.

In general I think we should review such scorers and make a decision on a case-by-case basis.
For BS, I'd like to change it since I don't see any back-compat issue, and it should clear
the code a bit. I'll go ahead and do it, and if I run into any obstacles I'll post back.

> Add next() and skipTo() variants to DocIdSetIterator that return the current doc, instead
of boolean
> ----------------------------------------------------------------------------------------------------
>                 Key: LUCENE-1614
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: Search
>            Reporter: Shai Erera
>             Fix For: 2.9
>         Attachments: LUCENE-1614.patch, LUCENE-1614.patch, LUCENE-1614.patch
> See
for the full discussion. The basic idea is to add variants to those two methods that return
the current doc they are at, to save successive calls to doc(). If there are no more docs,
return -1. A summary of what was discussed so far:
> # Deprecate those two methods.
> # Add nextDoc() and skipToDoc(int) that return doc, with default impl in DISI (calls
next() and skipTo() respectively, and will be changed to abstract in 3.0).
> #* I actually would like to propose an alternative to the names: advance() and advance(int)
- the first advances by one, the second advances to target.
> # Wherever these are used, do something like '(doc = advance()) >= 0' instead of comparing
to -1 for improved performance.
> I will post a patch shortly

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message