lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael McCandless (JIRA)" <>
Subject [jira] Commented: (LUCENE-1614) Add next() and skipTo() variants to DocIdSetIterator that return the current doc, instead of boolean
Date Thu, 21 May 2009 15:34:45 GMT


Michael McCandless commented on LUCENE-1614:

On the other end of the scale... getting rid of "if (firstTime)" is another check I've long
wanted to eliminate.
if doc() produced -1 the first time, before any calls to next() or skipTo(), we could get
rid of the if (firstTime) code in ConjunctionScorer and others I think. The question is, would
this be a burden to any scorers or DISI implementations?


Since we're changing DISI's semantics, now seems like a great time to make this change to.
 Eliminating the "if (firstTime)" from next() would be great.

But: wouldn't ConjunctionScorer still need an init() to sort its sub-scorers?  (Though, really,
we ought to do that sort based on more accurate criteria, eg add a DIS.approxCount() (the
first docID of each sub-scorer is an approximation that could easily be very wrong).  If we
had that, then in the ConjunctionScorer's ctor we would do the ordering).

> Add next() and skipTo() variants to DocIdSetIterator that return the current doc, instead
of boolean
> ----------------------------------------------------------------------------------------------------
>                 Key: LUCENE-1614
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: Search
>            Reporter: Shai Erera
>             Fix For: 2.9
>         Attachments: LUCENE-1614.patch, LUCENE-1614.patch
> See
for the full discussion. The basic idea is to add variants to those two methods that return
the current doc they are at, to save successive calls to doc(). If there are no more docs,
return -1. A summary of what was discussed so far:
> # Deprecate those two methods.
> # Add nextDoc() and skipToDoc(int) that return doc, with default impl in DISI (calls
next() and skipTo() respectively, and will be changed to abstract in 3.0).
> #* I actually would like to propose an alternative to the names: advance() and advance(int)
- the first advances by one, the second advances to target.
> # Wherever these are used, do something like '(doc = advance()) >= 0' instead of comparing
to -1 for improved performance.
> I will post a patch shortly

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message