Return-Path: Delivered-To: apmail-lucene-java-dev-archive@www.apache.org Received: (qmail 10045 invoked from network); 29 Apr 2009 20:07:01 -0000 Received: from hermes.apache.org (HELO mail.apache.org) (140.211.11.3) by minotaur.apache.org with SMTP; 29 Apr 2009 20:07:01 -0000 Received: (qmail 69535 invoked by uid 500); 29 Apr 2009 20:07:00 -0000 Delivered-To: apmail-lucene-java-dev-archive@lucene.apache.org Received: (qmail 69470 invoked by uid 500); 29 Apr 2009 20:07:00 -0000 Mailing-List: contact java-dev-help@lucene.apache.org; run by ezmlm Precedence: bulk List-Help: List-Unsubscribe: List-Post: List-Id: Reply-To: java-dev@lucene.apache.org Delivered-To: mailing list java-dev@lucene.apache.org Received: (qmail 69462 invoked by uid 99); 29 Apr 2009 20:07:00 -0000 Received: from nike.apache.org (HELO nike.apache.org) (192.87.106.230) by apache.org (qpsmtpd/0.29) with ESMTP; Wed, 29 Apr 2009 20:07:00 +0000 X-ASF-Spam-Status: No, hits=-2000.0 required=10.0 tests=ALL_TRUSTED X-Spam-Check-By: apache.org Received: from [140.211.11.140] (HELO brutus.apache.org) (140.211.11.140) by apache.org (qpsmtpd/0.29) with ESMTP; Wed, 29 Apr 2009 20:06:51 +0000 Received: from brutus (localhost [127.0.0.1]) by brutus.apache.org (Postfix) with ESMTP id C73D1234C04C for ; Wed, 29 Apr 2009 13:06:30 -0700 (PDT) Message-ID: <1633061847.1241035590814.JavaMail.jira@brutus> Date: Wed, 29 Apr 2009 13:06:30 -0700 (PDT) From: "Michael McCandless (JIRA)" To: java-dev@lucene.apache.org Subject: [jira] Commented: (LUCENE-1614) Add next() and skipTo() variants to DocIdSetIterator that return the current doc, instead of boolean In-Reply-To: <848873297.1240634970628.JavaMail.jira@brutus> MIME-Version: 1.0 Content-Type: text/plain; charset=utf-8 Content-Transfer-Encoding: 7bit X-JIRA-FingerPrint: 30527f35849b9dde25b450d4833f0394 X-Virus-Checked: Checked by ClamAV on apache.org [ https://issues.apache.org/jira/browse/LUCENE-1614?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12704302#action_12704302 ] Michael McCandless commented on LUCENE-1614: -------------------------------------------- bq. I think I prefer advance(int target) OK +1. Nice and succinct. {quote} What do you mean "do not do a next()"? Let's say I have a DISI that can return docs 1, 3, 7, 10 but it doesn't know so in advance. When you call skipTo(8), it must reach 7, then figure it's less than 8 and do a next() to land on 10. Do you mean that it should return false in that case, and not move from 7 to 10? Since it already moved, and let's assume it cannot go back (at least efficiently), that means it should remember the last skipTo called was 8 and it is on 10, so if it is requested to skip to 9, it should return false again ... is that what you meant? {quote} I mean the scorer should go straight to the doc I asked for and test whether it accepts that doc and do nothing else. Call this api "boolean check(int doc)" for now. It'd be useful for more interesting scorers. EG ConjunctionScorer.check would simply call check on each sub-scorer, stopping early if any return false; this is less work than what it does today. You're right, for the TermScorer case nothing is saved since it uses next internally to determine if a doc matches. > Add next() and skipTo() variants to DocIdSetIterator that return the current doc, instead of boolean > ---------------------------------------------------------------------------------------------------- > > Key: LUCENE-1614 > URL: https://issues.apache.org/jira/browse/LUCENE-1614 > Project: Lucene - Java > Issue Type: Improvement > Components: Search > Reporter: Shai Erera > Fix For: 2.9 > > > See http://www.nabble.com/Another-possible-optimization---now-in-DocIdSetIterator-p23223319.html for the full discussion. The basic idea is to add variants to those two methods that return the current doc they are at, to save successive calls to doc(). If there are no more docs, return -1. A summary of what was discussed so far: > # Deprecate those two methods. > # Add nextDoc() and skipToDoc(int) that return doc, with default impl in DISI (calls next() and skipTo() respectively, and will be changed to abstract in 3.0). > #* I actually would like to propose an alternative to the names: advance() and advance(int) - the first advances by one, the second advances to target. > # Wherever these are used, do something like '(doc = advance()) >= 0' instead of comparing to -1 for improved performance. > I will post a patch shortly -- This message is automatically generated by JIRA. - You can reply to this email to add a comment to the issue online. --------------------------------------------------------------------- To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org For additional commands, e-mail: java-dev-help@lucene.apache.org