lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Uwe Schindler (JIRA)" <>
Subject [jira] Commented: (LUCENE-1561) Maybe rename Field.omitTf, and strengthen the javadocs
Date Tue, 07 Apr 2009 16:30:13 GMT


Uwe Schindler commented on LUCENE-1561:

I found a deprecation bug:
setOmitTf() and other are only deprecated in the Fieldable interface, but not in the implementations.
Code using setOmitTf() does not show a warning. So in AbstractField/Field, the @deprecated
should be added, too.

And a problem with SOLR:
The ChangeLog should clearly say, that the Fieldable interface was again changed. Plugging
the new Lucene JAR into Solr fails, because one of the Fieldable implementations of Solr do
not have the new methods.
Maybe we should remove the rename inside the interfae (keep omitTf there) and only change
it in the Field/AbstractField class. This would make jar-replacements possible. As most people
will not implement Fieldable, I think it can be left out (as it is only a rename). And generally
Interface should not have duplicate method declarations with different names because of deprecation...
(that looks very bad)

> Maybe rename Field.omitTf, and strengthen the javadocs
> ------------------------------------------------------
>                 Key: LUCENE-1561
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: Index
>    Affects Versions: 2.4.1
>            Reporter: Michael McCandless
>            Assignee: Michael McCandless
>             Fix For: 2.9
>         Attachments: LUCENE-1561.patch
> Spinoff from here:
> Maybe rename omitTf to something like omitTermPositions, and make it clear what queries
will silently fail to work as a result.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message