lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shai Erera (JIRA)" <>
Subject [jira] Commented: (LUCENE-1614) Add next() and skipTo() variants to DocIdSetIterator that return the current doc, instead of boolean
Date Thu, 30 Apr 2009 10:40:30 GMT


Shai Erera commented on LUCENE-1614:

bq. Not sure what you mean by "testAndSet-like version"?

I mean, instead of having the code call check(8), get true and then advance(8), just call
checkAndAdvance(8) which returns true if 8 is supported and false otherwise, AND moves to
8. I don't propose to replace check() with it as sometimes you might want to check a couple
of DISIs before making a decision to which doc to advance, but it could save calling advance()
in case check() returns true.

bq. Yes it does have a good default impl, I think.

It _will_ have a good default impl, I can guarantee to try :). What I meant is that we should
have clear documentation about check() and nextDoc() and the possibility that check will be
called for doc Id 'X' and later nextDoc or advance will be called with 'X', in that case the
impl must ensure 'X' is not skipped, as is done today by TermScorer for example.

So should I add this check()?

> Add next() and skipTo() variants to DocIdSetIterator that return the current doc, instead
of boolean
> ----------------------------------------------------------------------------------------------------
>                 Key: LUCENE-1614
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: Search
>            Reporter: Shai Erera
>             Fix For: 2.9
> See
for the full discussion. The basic idea is to add variants to those two methods that return
the current doc they are at, to save successive calls to doc(). If there are no more docs,
return -1. A summary of what was discussed so far:
> # Deprecate those two methods.
> # Add nextDoc() and skipToDoc(int) that return doc, with default impl in DISI (calls
next() and skipTo() respectively, and will be changed to abstract in 3.0).
> #* I actually would like to propose an alternative to the names: advance() and advance(int)
- the first advances by one, the second advances to target.
> # Wherever these are used, do something like '(doc = advance()) >= 0' instead of comparing
to -1 for improved performance.
> I will post a patch shortly

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message