lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael McCandless (JIRA)" <j...@apache.org>
Subject [jira] Commented: (LUCENE-1561) Maybe rename Field.omitTf, and strengthen the javadocs
Date Tue, 07 Apr 2009 17:14:13 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-1561?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12696628#action_12696628
] 

Michael McCandless commented on LUCENE-1561:
--------------------------------------------

bq. setOmitTf() and other are only deprecated in the Fieldable interface, but not in the implementations.
Code using setOmitTf() does not show a warning. So in AbstractField/Field, the @deprecated
should be added, too.

Urgh, I'll add @deprecated to the methods in AbstractField.java.

bq. Maybe we should remove the rename inside the interfae (keep omitTf there) and only change
it in the Field/AbstractField class. 

Darned interface!  The problem with this is we use this interface from within Lucene, to access
OTFAP, so we'd have to switch those back to deprecated calls, though it does look to be in
only a few places.  It's also confusing to deprecate it in Fieldable & AbstractField but
not offer the non-deprecated variant in Fieldable.  Since it's possible we won't get the "cleanup
Fieldable/AbstractField/Field" done for 2.9, I'd like in 3.0 to be able to consistently name
it in both the Fieldable interface and the AbstractField abstract class.  Or are you thinking
we'd leave omitTf in Fieldable and then in 3.0 forcefully rename it to omitTermFreqAndPositions?

> Maybe rename Field.omitTf, and strengthen the javadocs
> ------------------------------------------------------
>
>                 Key: LUCENE-1561
>                 URL: https://issues.apache.org/jira/browse/LUCENE-1561
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: Index
>    Affects Versions: 2.4.1
>            Reporter: Michael McCandless
>            Assignee: Michael McCandless
>             Fix For: 2.9
>
>         Attachments: LUCENE-1561.patch
>
>
> Spinoff from here:
>   http://www.nabble.com/search-problem-when-indexed-using-Field.setOmitTf()-td22456141.html
> Maybe rename omitTf to something like omitTermPositions, and make it clear what queries
will silently fail to work as a result.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org


Mime
View raw message