lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael McCandless (JIRA)" <>
Subject [jira] Commented: (LUCENE-1614) Add next() and skipTo() variants to DocIdSetIterator that return the current doc, instead of boolean
Date Wed, 29 Apr 2009 20:06:30 GMT


Michael McCandless commented on LUCENE-1614:

bq. I think I prefer advance(int target)

OK +1.  Nice and succinct.

What do you mean "do not do a next()"? Let's say I have a DISI that can return docs 1, 3,
7, 10 but it doesn't know so in advance. When you call skipTo(8), it must reach 7, then figure
it's less than 8 and do a next() to land on 10. Do you mean that it should return false in
that case, and not move from 7 to 10? Since it already moved, and let's assume it cannot go
back (at least efficiently), that means it should remember the last skipTo called was 8 and
it is on 10, so if it is requested to skip to 9, it should return false again ... is that
what you meant?

I mean the scorer should go straight to the doc I asked for and test whether it accepts that
doc and do nothing else.  Call this api "boolean check(int doc)" for now.

It'd be useful for more interesting scorers.  EG ConjunctionScorer.check would simply call
check on each sub-scorer, stopping early if any return false; this is less work than what
it does today.

You're right, for the TermScorer case nothing is saved since it uses next internally to determine
if a doc matches.

> Add next() and skipTo() variants to DocIdSetIterator that return the current doc, instead
of boolean
> ----------------------------------------------------------------------------------------------------
>                 Key: LUCENE-1614
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: Search
>            Reporter: Shai Erera
>             Fix For: 2.9
> See
for the full discussion. The basic idea is to add variants to those two methods that return
the current doc they are at, to save successive calls to doc(). If there are no more docs,
return -1. A summary of what was discussed so far:
> # Deprecate those two methods.
> # Add nextDoc() and skipToDoc(int) that return doc, with default impl in DISI (calls
next() and skipTo() respectively, and will be changed to abstract in 3.0).
> #* I actually would like to propose an alternative to the names: advance() and advance(int)
- the first advances by one, the second advances to target.
> # Wherever these are used, do something like '(doc = advance()) >= 0' instead of comparing
to -1 for improved performance.
> I will post a patch shortly

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message