lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marvin Humphrey (JIRA)" <>
Subject [jira] Commented: (LUCENE-1614) Add next() and skipTo() variants to DocIdSetIterator that return the current doc, instead of boolean
Date Tue, 28 Apr 2009 15:30:30 GMT


Marvin Humphrey commented on LUCENE-1614:

Further illustration...

Good method signature overloading, from

  public static boolean indexExists(String directory)

  public static boolean indexExists(File directory)

  public static boolean indexExists(Directory directory);

Bad method signature overloading, from

  public Hits search(Query query, Filter filter, Sort sort)

  public TopFieldDocs search(Query query, Filter filter, int n, Sort sort)

  public void search(Query query, HitCollector results)

IMO, those three methods on Searcher should be named hits(), topFieldDocs(),
and collect(), rather than search(), search(), and search(), making code that
uses those methods more self documenting, and making it easier to discuss them
out of context.

For the same reasons, we should have different names for nextDoc() and

> Add next() and skipTo() variants to DocIdSetIterator that return the current doc, instead
of boolean
> ----------------------------------------------------------------------------------------------------
>                 Key: LUCENE-1614
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: Search
>            Reporter: Shai Erera
>             Fix For: 2.9
> See
for the full discussion. The basic idea is to add variants to those two methods that return
the current doc they are at, to save successive calls to doc(). If there are no more docs,
return -1. A summary of what was discussed so far:
> # Deprecate those two methods.
> # Add nextDoc() and skipToDoc(int) that return doc, with default impl in DISI (calls
next() and skipTo() respectively, and will be changed to abstract in 3.0).
> #* I actually would like to propose an alternative to the names: advance() and advance(int)
- the first advances by one, the second advances to target.
> # Wherever these are used, do something like '(doc = advance()) >= 0' instead of comparing
to -1 for improved performance.
> I will post a patch shortly

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message