lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael McCandless (JIRA)" <>
Subject [jira] Commented: (LUCENE-1561) Maybe rename Field.omitTf, and strengthen the javadocs
Date Tue, 07 Apr 2009 21:08:13 GMT


Michael McCandless commented on LUCENE-1561:

bq. Wasn't it the plan to remove these interfaces in 3.0?

That would be fabulous.  How would you do it?  Collapse everything down to concrete Field
(no more interface nor abstract base class)?  Make type/use specific subclasses (eg NumericField)?
 What would you replace IndexReader.document with?  Would we better/explicitly represent multi-valued

bq. We could deprecate Fieldable in complete and leave it as it is.

I think that's a good fallback if we can't get the full cleanup of Field/Document done for

I guess in either of these two cases, we would want to leave Fieldable unchanged (ie put back
only the deprecated omitTf), so I'll make that change now.

> Maybe rename Field.omitTf, and strengthen the javadocs
> ------------------------------------------------------
>                 Key: LUCENE-1561
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: Index
>    Affects Versions: 2.4.1
>            Reporter: Michael McCandless
>            Assignee: Michael McCandless
>             Fix For: 2.9
>         Attachments: LUCENE-1561.patch
> Spinoff from here:
> Maybe rename omitTf to something like omitTermPositions, and make it clear what queries
will silently fail to work as a result.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message