lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Uwe Schindler (JIRA)" <>
Subject [jira] Commented: (LUCENE-1561) Maybe rename Field.omitTf, and strengthen the javadocs
Date Tue, 07 Apr 2009 18:06:13 GMT


Uwe Schindler commented on LUCENE-1561:

Wasn't it the plan to remove these interfaces in 3.0?

We could deprecate Fieldable in complete and leave it as it is.From Lucene 3.0 on we only
have AbstractField. So the old Fieldable interface must be used internally until 3.0 (with
the deprecated methods), but user-land code like Solr should only overwrite AbstractField
and not implement the interface anymore (I am not really sure, why Solr needs this Fieldable
implementation at all, it the only place in Solr where problems occur, it would be good to
reimplement this internal class using AbstractField).

Document.add() and all other public appearences of Fieldable should be overloaded with AbstractField
counterparts and so on, so that all public API only use the abstract class anymore.

But thats my opinion, and maybe is related to the other issue "whole document/field reimplementation".

> Maybe rename Field.omitTf, and strengthen the javadocs
> ------------------------------------------------------
>                 Key: LUCENE-1561
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: Index
>    Affects Versions: 2.4.1
>            Reporter: Michael McCandless
>            Assignee: Michael McCandless
>             Fix For: 2.9
>         Attachments: LUCENE-1561.patch
> Spinoff from here:
> Maybe rename omitTf to something like omitTermPositions, and make it clear what queries
will silently fail to work as a result.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message