lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael McCandless <>
Subject Re: move TrieRange* to core?
Date Wed, 18 Mar 2009 22:07:42 GMT

Uwe Schindler wrote:

> I would be happy with a renaming to "NumberRangeFilter", but "trie"  
> should appear somewhere in the docs.

I like this approach (and referencing the original paper); I think
it's important the javadocs give enough detail about how it works so
that one can understand the big picture and what precisionStep does,
but I think the name should more reflect how it's used rather than how
it's implemented.

I realize TrieRangeFilter can be used for anything that can be
accurately represented as int or long in Java (eg Date), but I would
expect numeric sorting/range-filtering is the vast majority of cases.

Naming is the hardest part!


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message