lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael McCandless <>
Subject Re: Is TopDocCollector's collect() implementation correct?
Date Thu, 26 Mar 2009 12:44:57 GMT
Earwin Burrfoot <> wrote:

> I'd say it is a bad name. Raw hit is way far from being result of a search.

First off, from Lucene's standpoint, the docID *is* the result of the
search.  Your application will do further things (load titles, do
higlighting, etc.) with that result.

Second off, since ResultCollector is an abstract base class, it would
be subclassed to concrete versions that do more interesting things
(call Scorer.score(), etc) so as to make up what your application
considers the "result".

So I understand your objection, but I still feel ResultCollector is an OK name.

Or do you have an alternative?


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message