lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Earwin Burrfoot <ear...@gmail.com>
Subject Re: Is TopDocCollector's collect() implementation correct?
Date Thu, 26 Mar 2009 12:19:28 GMT
I'd say it is a bad name. Raw hit is way far from being result of a search.

If you're already breaking back compat with 3.0 release (by
incrementing java version), maybe its worthy to break it in some more
places, just so ugly names like MRHC and special code paths that check
for n-year-old interfaces won't haunt us for the next century.

On Thu, Mar 26, 2009 at 14:15, DM Smith <dmsmith555@gmail.com> wrote:
>
> On Mar 26, 2009, at 6:55 AM, Michael McCandless wrote:
>
>>  think we need to deprecate HC, in favor of MRHC (or if we can think
>> of a better name... ResultCollector?).
>
> I like your suggestion for the name.
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
> For additional commands, e-mail: java-dev-help@lucene.apache.org
>
>



-- 
Kirill Zakharenko/Кирилл Захаренко (earwin@gmail.com)
Home / Mobile: +7 (495) 683-567-4 / +7 (903) 5-888-423
ICQ: 104465785

---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org


Mime
View raw message