lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Uwe Schindler" <...@thetaphi.de>
Subject RE: move TrieRange* to core?
Date Wed, 18 Mar 2009 21:45:06 GMT
> >> I think we should move TrieRange* into core before 2.9?
> >>
> >> It's received alot of attention, from both developers (Uwe & Yonik did
> >> lots of iterations, and Solr is folding it in) and user interest.
> >>
> >> It's a simpler & more scalable way to index numeric fields that you
> >> intend to sort and/or do range querying on; we can do away with tricky
> >> number padding.
> >>
> >> Plus it's just plain cool :)
> >>
> >> I also think we should change its name.  I know and love "trie", but
> >> it's a very technical term that's not immediately meaningful to users
> >> of Lucene's API.  Plus I've learned from doing too many renamings
> >> lately that it's best to try to get the name right at the start.
> >>
> >> Maybe just NumberUtils, IntRangeFilter, LongRangeFilter,
> >> AbstractNumberRangeFilter?
> >
> > +1
> >
> > How about NumericRangeFilter ?
> The idea behind this filter can be applied to more than just numbers,
> so I'd like to put the stress on its speed or idea used -
> FastRangeQuery, TrieRangeQuery, SegmentedRangeQuery (from the fact it
> splits input range into variable-precision segments), PrefixRangeQuery
> (you can reword the algorithm in terms of prefixes)

Trie  is also known as Prefix Tree, because of that and the usage, I called it TrieRange [see
http://en.wikipedia.org/wiki/Trie: the original term "trie" comes from "retrieval." Following
the etymology, the inventor, Edward Fredkin, pronounces it [tɹi] ("tree"). However, it is
pronounced [tɹaɪ] ("try") by other authors].

So we have two possibilities:

- a generic name completely hiding the internals -- but then the complexity with the helper
field should be hidden, how should "precisionStep" called and justified then?
- a name describing how it works, like Earwin suggested - so we could stay with TrieRange.


The name "TrieRangeQuery" first appeared in [1], so it should be noted somewhere, even if
it is renamed to NumberRangeFilter or something else... :-) I would be happy with a renaming
to "NumberRangeFilter", but "trie" should appear somewhere in the docs.

Uwe

[1] Schindler, U, Diepenbroek, M, 2008. Generic XML-based Framework for Metadata Portals.
Computers & Geosciences 34 (12), 1947-1955. doi:10.1016/j.cageo.2008.02.023


---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org


Mime
View raw message