lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael McCandless <luc...@mikemccandless.com>
Subject Re: Where to download package org.apache.lucene.search.trie
Date Mon, 26 Jan 2009 11:58:38 GMT

Moving thread to java-dev...

Uwe Schindler wrote:

> You can use the artifact from Hudson as Mike told, but the JAR file  
> is not
> compatible with Lucene 2.4 (because a new SortField constructor for  
> sorting
> against trie encoded fields and the new Superinterface  
> FieldCache.Parser
> leading to ClassNotFoundEx).

Ugh -- this is no good: it's a break to our back-compat, I think?  Ie  
when we
say "complete API back-compatbility", here:

     http://wiki.apache.org/lucene-java/BackwardsCompatibility

We mean you can drop in new JAR and run your app w/ no problems, right?

Uwe, how could we fix it (LUCENE-1478) so we get back to "drop-in new  
JAR"
back compatibility?

Also, it'd be great to fix "ant test-tag" to somehow test "jar drop-in  
back compat",
vs "full recompilation against new JAR" that it does today.  It'd have  
to check out
the full sources on the back-compat tag, compile JAR & tests from  
those old
sources, swap in new JAR, then run the tests.

Mike

---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: java-dev-help@lucene.apache.org


Mime
View raw message